Banner Diaspora LiGNUx
Banner foro LiGNUx

Habilitar el dual boot en sistemas EFI

bootrepairLos equipos actuales vienen con el sistema EFI, este sistema es una especificación desarrollada por Intel dirigida a reemplazar la antigua interfaz del estándar IBM PC BIOS, e interactúa como puente entre el sistema operativo y el firmware base.

Este sistema causó un gran revuelo, ya que Microsoft llegó a un acuerdo con los constructores de hardware para que incluyesen éste sistema en las nuevas placas, para así poder evitar la posible instalación de determinadas distribuciones GNU/Linux y con ello dejar fuera de juego a posibles competidores, incluso UEFI y Secure Boot fueron denunciados por HispaLinux ante la Comisión Europea.

Pues tengo malas noticias para Microsoft ya que he descubierto la forma de poder instalar Linux en equipos nuevos y borrar del mapa a su querido Windows 8 xD.

La instalación se realiza correctamente, pero los problemas empiezan al reiniciar el equipo dando errores, para corregir esto, necesitaremos el Boot Repair.

Cuando instalemos Ubuntu (por ejemplo) antes de reiniciar instalaremos Boot Repair en nuestro equipo con los siguientes comandos:

sudo add-apt-repository ppa:yannubuntu/boot-repair

sudo apt-get update

sudo apt-get install boot-repair

Lo ejecutamos y hacemos click en “Recommended repair” y en “Advanced options” encontraremos una opción que activa o desactiva el soporte Secure Boot y con ello la solución.

boot-repair

Banner foro LiGNUx
Banner Diaspora LiGNUx

Acerca de Jessica

Fan del software libre, Open Source y GNU/Linux!

Visita también

kernel-linux

Tutorial para instalar la versión de mantenimiento del kernel Linux 4.6.4

Antes de ayer se publico la cuarta versión de mantenimiento del kernel 4.6, siendo esta …

42 Comentarios

  1. Hola, muy buenas tardes o noches (XD) quisiera que me ayudaran a instalar linux 14.04, la verdad no tengo dinero para un curso de programación y deseo aprender programación utilizando GNU/linux, el problema es que mi laptop (pavilion g4 g4 2205la) tiene pre instalado UEFI y por mas que he tratado no puedo instalar ubuntu… agradecería muchísimo que me dieran un pequeño tutorial básico para poder instalar ubuntu, muchas gracias por su atención y saludos.

  2. Hola a todos, tengo una gran duda respecto a mi notebook, una toshiba l845 i5, con ese bendito uefi que me trajo preinstalado windows8, y en un tiempo se me frego por un corto en el cargor, asi q baje el disco modo desarrolladores y pudes reinstalar windows 8 desde el windows 8 para desarrolladores que permitia uefi, ahora va mi duda, mi compre un sdd, funciona con uefi? o tengo que desactivarlo y activar AHCI???? Att.estudiante de ingenieria en informatica.:-(

  3. Bueno, cualquier cosa, me avisas en este mensaje, es que se han hecho tan largas las citas que ya es difícil leer una palabra, y más en una pantalla de 10″ de la netbook.
    Mientras tanto, seguiré viendo en la BIOS, pero mi mouse inalámbrico murió, no se que le pasa. Hoy me tocaron todas xDD.

    • Si tienes UEFI pero no Secure Boot, igual te conviene mirar como instalarlo con uefi, ahora vienen con el disco formateado con sistema GPT, que no es lo mismo que MBR. Este sistema permite muchas mas particiones primarias, pero la instalación no es igual, si viene con GPT, y desactivas uefi en la bios, posiblemente haya que cambiar el disco de GPT a MBR, y es muy normal perder el arranque y no poder recuperarlo. El particionado es diferente, hay que hacer particion /boot solo para que el arranque pueda encontrarla y desde ahi iniciar el arranque “normal”. Aunque más cómodo sería que pudieras desactivar uefi.

      • bueno, hoy estube dándome con la cabeza un par de veces, es más, me había bajado Ubuntu par probar, y me había dado errores, por lo que me dio una pista… errores en las tablas de particiones. En ubuntu, no pude, pero volví a eOS desde Recovery Mode (el único modo que podía entrar) y me salió que necesitaba los drivers para mi placa de video. Los descargué, reinicié la PC y… ¡ahora estoy desde el modo normal! no creo que eso lo haya resuelto, algo raro pasó en el medio. Igual voy a reiniciar, a ver si me da algún error nuevamente xD.

        • Me alegro que se haya solucionado algo! Ya me contarás, es que era muy extraño lo que te sucedía jejeeje

          • xD, al final, no me detectaba el disco de 500GB, al parecer fui tan pelo$%&$ que no lo seteé para /home y no podía loguearme. Así que como el SSD es relativamente nuevo, dije, a la mierda todo, reinstalo por 4ºta o 5ºta vez seteando todo como tiene que ser y listo. Ahora no seguí ningún paso de este tema, y con solo instalar los drivers de la placa de video funcionó xD.
            Gracias igual! Hoy voy a poder disfrutar el “viernes a la noche” fuckyeah 😀 Mis papás se van y yo pongo música, así de simple ^^

  4. Hola, pasé de Windows 7 a eOS 64 Bits y ya lo instalé, pero no funciona xD, a pesar de haber puesto este programa y tildar lo que dice, PERO en mi caso la casilla “Backup and rename EFI files” no está 🙁
    Alguna solución? Tengo una Bios UEFI, y un motherboard con Chipset Z77. Lógicamente, el SSD donde tenía Win7 se formateó al instalar eOS, y tengo otro de 500GB con mis documentos. Ya es la 4°ta vez que lo instalo jaja, y ya veo que esa no es la solución. Desde ya gracias por contestar.

    • Lo que puede ocurrir es que el grub no se quede instalado, para ello bootea en modo live y añade en la terminal estos comandos, vamos a suponer que en /dev/sda1 está la partición efi y en /dev/sda6 la partición de la raiz de elementary ok?

      sudo -i
      mount /dev/sda6 /mnt
      mount /dev/sda1 /mnt/boot
      grub-install –root-directory=/mnt/ /dev/sda
      mount –bind /proc /mnt/proc
      mount –bind /dev /mnt/dev
      mount –bind /sys /mnt/sys
      chroot /mnt update-grub
      umount /mnt/sys
      umount /mnt/dev
      umount /mnt/proc
      exit

      Espero te sirva de ayuda

      • si, ya lo hice, el SSD esté primero. ¿Es muy relevante el casillero que no está presente en el programa? (lo comenté en mi comment. anterior).

        • solamente puedo usar el S.O si entro en eOS (recovery mode), pero se ve a 1024×768 o similar, y no creo que me deje instalar el Driver de mi GPU, ¿o si? 😛

          • Um… antes de nada, 1º instalaste windows y después Gnu Linux ¿cierto?, cada uno en su partición correspondiente ¿si?

            • No no, yo tenía instalado Windows en el SSD y ahora tengo eOS, pero no puedo entrar (ahora estoy desde el Live Demo del USB xD).

              • Jum… necesitaría ver tu bios, me da que es algo de ahí

                • xD en Midori no se pueden ver los videos de Youtube porque no tiene flash, y cuándo activo la versión de HTML5 dice que no está disponible el video… 😛

                  Mi bios no es EFI, es UEFI, y mi mother es un Asus P8Z77-V, que tengo entendido, son las mismas Bios que el P8Z77-V Deluxe y P8Z77-M Pro.
                  Desde ya gracias si googleas. O al menos sabes como saber el nombre de la partición del UEFI, también ayuda, que creo que es lo único que falta jeje.
                  Un saludo y gracias 😀

                  • UEFI y EFI es lo mismo jejeje, vale voy a ver si encuentro la solución, y te comentaré, posiblemente la partición uefi ya la hayas eliminado, eso era por si quedaba por ahí oculta. de todas formas buscaré info y te avisaré con lo que sea, saludos!

                    • no sabía xD.
                      Bueno, por ahora no puedo hacer otra cosa que darte las gracias, de todas formas, voy a seguir probando con lo que dice el Post, a ver si cambio algo xDD.

                    • Es que sé que en la bios hay que cambiar el uefi por MBR, pero no recuerdo si era en el apartado boot o en cual… buscaré, y nada que agradecer para eso estamos! 🙂

      • Hola, antes que nada, fui a GParted para saber que “número” tenía cada partición. Me refiero a los nombres ‘sda1’ / ‘sda2’ / etc.
        Me encontré con esto:

        – /dev/sda1 | ext4 | 47.95GiB-
        – /dev/sda2 | extended | 7.95GiB –
        – (dentro de /dev/sda2) /dev/sda5 | linux-swap | 7,95GiB –

        ——————————–

        ¿Cuál se supone que es el del UEFI? porque al parecer, en mi caso /dev/sda1 es la partición de elementary, pero, ¿el de UEFI? ya que pongo en la terminal mount /dev/sda6 /mnt (imaginándome que es la partición de UEFI) pero eOS dice que no existe 🙁

      • Hola, antes que nada, fui a GParted para saber que “número” tenía cada partición. Me refiero a los nombres ‘sda1′ / ‘sda2′ / etc.
        Me encontré con esto:

        – /dev/sda1 | ext4 | 47.95GiB-
        – /dev/sda2 | extended | 7.95GiB –
        – (dentro de /dev/sda2) /dev/sda5 | linux-swap | 7,95GiB –

        ——————————–

        ¿Cuál se supone que es el del UEFI? porque al parecer, en mi caso /dev/sda1 es la partición de elementary, pero, ¿el de UEFI? ya que pongo en la terminal mount /dev/sda6 /mnt (imaginándome que es la partición de UEFI) pero eOS dice que no existe 🙁

  5. Siempre he querido saber esto aunque no he tenido la necesidad de hacerlo, se que algún depronto me toque 🙂

  6. Hola de nuevo, llevo aquí un buen rato buscando por internet y probando pero no consigo que funcione. Pasa lo siguiente:
    Al instalar boot-repair y ejecutarlo me da un error diciendo que no encuentra el archivo .Xauthorization, entonces intento entrar en el programa estando en modo root y accede, pero, al ejecutar “recommended repair”, aparece un error diciendo “grub-pc purge cancelled”.

    ¿Qué puedo hacer?

    Un saludo y gracias de nuevo.

    • ¿Lo instalarte bien?
      Tienes aquí un tuto para instalar y usarlo: boot repair

      • En teoría si, a ver explico lo que hago vaya que la esté liando en algo:
        -Cuando se termina de instalar el SO me dice: se necesita reiniciar…
        -No lo reinicio y abro el terminal y sigo el procedimiento de instalación por terminal (no tengo lector de cd aun)..
        -Cuando se termina de instalar me da un error. Pone exactamente esto:
        “debconf:DbDriver “config”: /var/cache/debconf/config-dat is locked by another process: Resource temporarily unavailable”
        “dpkg: error processing man-db (–unpack): subprocess installed post-installation script returned error exit status 1”
        -Pero me fijo y en aplicaciones está el programa, lo ejecuto y sale el error que dije ayer. Hago en el terminal sudo su y lo ejecuto desde ahí y si se abre pero al hacer lo de reparación recomendada me da ese error.

        • ¿Y si hubieras reiniciado cuando te lo pide? ¿te seguiría dando problemas?

          • Si reinicio cuando me lo pide no puedo volver a entrar en elementary os (o eso creo) porque tiene el sistema UEFI y no me aparece el GRUB cuando inicio ni nada por el estilo.

            • Probaste esto: Reinicias, arrancas desde tu cd de Elementary, instalas boot repair y ejecutas, reinicias y ya todo listo. Tienes aquí algo de info.

              • Nada sigue sin funcionar. He mandado un correo al soporte de boot-repair con la url que me aparece al hacer el summary a ver que me dicen ellos.

                Gracias por vuestra atención!

  7. Me imagino que este problema solo pasa al instalar Linux junto al windows instalado ocupando tooodo el disco duro, por que al formatear todo e instalar windows con su respectiva particion y dejando otra particion para Linux, no hay problema; o me equivoco?
    Saludos.

    • Si la mayoría de veces que se da este caso es por instalar windows después de una distro gnu linux, ya que este es tan especial que siempre ha de ir antes.
      Si con 20gb tienes para meter una distro sin problema alguno.

  8. ¿Y que pasa si solo quiero tener instalado Linux en un laptop nuevo y borrar el W8 de fábrica? ¿tendré problemas?

    • Pues creo que es el mismo procedimiento, pero cargándote Windows también, ya que Efi lo que hace es un bloqueo a todo lo ajeno a Windows.

      • Hay que borrar el disco duro por completo, hace poco me pasó con un pc nuevo de una amiga recuerdas? Luego se hacen las particiones correspondientes, yo aconsejo crear una para guardar las cosas personales, así cuando se formatea y demás esa sigue intacta

  9. Muchas gracias Jessica, aún no he llegado a instalar en un equipo que viniera con windows 8 de fábrica, mi pc ya es bastante viejo y venia con Windows Vista, pero seguro que me vendrá bien en un futuro.

Deja un comentario

Tu dirección de correo electrónico no será publicada.