KaliyChromeVarios usuarios han tenido problemas con el tema de instalar Chrome en Kali Linux y he decidido ponerle remedio al asunto, espero poder solucionar este problema.

Kali Linux incluye por defecto el navegador  Iceweasel, pero por alguna razón no gusta y muchos usuarios quieren integrar el Chrome y lo descargan, pero éste no se puede ejecutar como raíz o root. Para poder ejecutarlo debemos instalarlo desde la consola Shell siguiendo estos pasos:

Abrimos la terminal e insertamos los siguientes comandos, no es necesario hacer “su” porque ya somos superusuarios

nano /etc/apt/sources.list

Nos saldrá un archivo donde le añadiremos el repositorio:

deb stable main

Y la llave del repositorio:

wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | apt-key add -

Una vez copiado iremos al archivo le damos a click derecho y elegimos la opción “Pegar“, guardaremos los cambios con “Ctrl + O“, le damos a ENTER y  salimos con “Ctrl + X“.

Ahora tendremos que actualizar Kali y aplicaremos las actualizaciones :

apt-get update

apt-get upgrade

Instalamos el Chrome:

sudo apt-get install google-chrome-stable

Una vez instalado vamos a solucionar el maldito error que no nos deja ejecutarlo como raíz, en una terminal ejecutamos este comando para editar el lanzador de Google:

leafpad /opt/google/chrome/google-chrome

En el final del archivo buscaremos esta línea:

exec -a "$0" "$HERE/chrome" "$@"

Una vez localizada al final le añadiremos esto sin borrar nada:

--user-data-dir

Y nos tiene que quedar así:

exec -a "$0" "$HERE/chrome" "$@" --user-data-dir

Guardamos los cambios con “Ctrl +  S“, cerraremos la ventana del editor de texto y comprobamos que Chrome funciona, tiene que estar en Aplicaciones>> Internet.

google-chrome-kali-linux

Este procedimiento lo he probado en mi Kali Linux en VirtualBox y funciona perfectamente, espero que os sirva de ayuda 🙂

56 COMENTARIOS

  1. la linea para chrome ahora tiene que quedar asi ” exec -a “$0” “$HERE/chrome” “$@” %U –no-sandbox –user-data-dir & ” sin las comillas y para los que usan chromium y ya no les abre , para que chromium les abra automaticamente deben poner en la terminal el siguiente comando ” leafpad /usr/bin/chromium ” sin las comillas y buscan la linea ” exec $LIBDIR/$APPNAME $CHROMIUM_FLAGS “$@” ” hacen un espacio y le agregan ” %U –no-sandbox –user-data-dir & ” sin las comillas guardan cierran y chromium ya les abrira de forma automatica al igual que chrome. espero a alguien le sirva.

  2. se entiende perfecto pero si no tienes unos conocimientos basicos no te enteras de que lo que tienes ue hacer es pegar el deb main en donde te sale cuando pones lo de nano/… le das a guardar sales y despues en la consolal normal pones la key… epero que resuelvas alguna duda jejjeejej 😉

  3. Hola. Tengo Problemas A La Hora De Instalar El Repositorio Porque No Se Donde Hay Que Pegar La Llave.

    Os Dejo Lo Que Tengo En La Terminal Hasta Ahora:

    # deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ – Official Snapshot i386 LIVE/INSTALL Binary 20160120-19:42]/ kali-rolling contrib main non-free

    #deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ – Official Snapshot i386 LIVE/INSTALL Binary 20160120-19:42]/ kali-rolling contrib main non-free

    deb stable main

  4. Donde pego la key? Llego hasta el punto de añadir la key pero no se donde pegarla si no es mucho pedir podriais poner fotos?

  5. Hola, he intentado instalar google chrome y me da el siguiente error:
    W: Error de GPG: stable Release: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY A040830F7FAC5991
    W: The repository ‘http://dl.google.com/linux/deb stable Release’ is not signed.
    N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: No existe ninguna clave pública disponible para los siguientes identificadores de clave:
    A040830F7FAC5991

      • No se entiende muy bien como se tienen que poner el repositorio y la clave, en la misma linea dan este error y si la clave va a la sigiente es el error que describe el compañero en la respuesta sigiente.

        • Que no se entiende muy bien?? El trabajo explicativo del compañero es excelente y metòdico, si no se entiende muy bien pues vaya a estudiar cocina porque esto no es lo suyo mi amigo, y la proxima no diga “no se entiende bien”, diga “no entiendo bien” Valeu cara de pau, começa valorar as coisas maluco.

  6. Hola! quizas sea algo viejo esto pero quisiera saber porque al ejecutar

    “apt-get update”

    Me sale esto:

    E: Tipo «wget» desconocido en la línea 2 de la lista de fuentes /etc/apt/sources.list
    E: Tipo «wget» desconocido en la línea 2 de la lista de fuentes /etc/apt/sources.list.d/sources.list
    E: No se pudieron leer las listas de fuentes.

  7. El tutorial está muy bien explicado, pocos se ven tan detallados; pero parece que la orden wget hay que ponerla en el archivo source.list en lugar de ejecutarla en la consola.

  8. Todo bien, hasta que llego a este punto:

    root@fulano:~# sudo apt-get install google-chrome-stable
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    No se pudieron instalar algunos paquetes. Esto puede significar que
    usted pidió una situación imposible o, si está usando la distribución
    inestable, que algunos paquetes necesarios aún no se han creado o se
    han sacado de «Incoming».
    La siguiente información puede ayudar a resolver la situación:

    Los siguientes paquetes tienen dependencias incumplidas:
    google-chrome-stable : Depende: libappindicator1 pero no es instalable
    E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

    ¿Alguien me puede decir que paquetes necesito? (Tengo Kali 2.0, Kernel 4.0.0-kali1-amd64 #1 SMP Debian 4.0.4-1+kali2 (2015-06-03) x86_64 GNU/Linux)

    Gracias

  9. Hola, les escribo para ver si alguien me puede ayudar. Cuando escribo la siguiente linea “sudo apt-get install google-chrome-stable” (obviamente sin comillas), me sale lo siguiente:

    “Leyendo lista de paquetes … Hecho
    Creando árbol de dependencias
    Leyendo la información de estado … Hecho
    E: no se ha podido localizar el paquete google-chrome-stable”

    Quisiera saber cómo puedo solucionarlo. Espero que me ayuden. Saludos.

  10. Buen dato omeza no me abria para nada el Chrome y use este codigo:
    exec -a “$0” “$HERE/chrome” “$PROFILE_DIRECTORY_FLAG” “$@” –user-data-dir
    y se soluciono el problema – Gracias tambn a MIchael58 ya que el codigo se ejecuta por el termina Y no se debe guardar en el sources.list

  11. Hola, estoy usando la version de kali armhf en una tablet china, con un nucleo a20. Lo instale con linux deploy y lo ejecuto con bvncfree, es increible lo bien que va tanto en lxde o xfce4, editando el .xinitrc. Si alguien sabe como hacer para que se ejecute en español ya que esta version armhf esta en ingles y no se si hay repositorios en español. Libreoffice corre en español, pero no encuentro la manera de ejecutar el corrector en español, tal vez falta agregarlo y tambien no encuentro el repositorio. Pudiendo solucionar estos dos temas seria la mejor distro corriendo en tablet. Se puede imprimir, conectar con entorno.Escribo este comentario dentro de la tablet y con iceweael. Gracias por su ayuda desde ya. Saludos desde Santa Fe, Argentina.

  12. He tratado de instalar chrome en mi kali pero al momento de poner
    exec -a “$0″ “$HERE/chrome” “$PROFILE_DIRECTORY_FLAG” “$@” –user-data-dir y guardarlo
    cuando lo quiero abrir, no lo abre ni me mando ningun mensaje

  13. Hola que tal a mi no me dejaba de alguna de las maneras, al final edite la linea asi:
    exec -a “$0” “$HERE/chrome” “$@” –user-data-dir
    y fue como me dio resultados.
    Saludos!

    Una mujer guapa atrae, pero que sepa de Linux enamora!!

  14. Me funcionó mi Chrome, lo unico que cambia es que mi linea queda asi:
    exec -a “$0” “$HERE/chrome” “$PROFILE_DIRECTORY_FLAG” \ “$@” –user-data-dir

    A la parte que agregue a la linea, le quite el guion largo – y lo dejé con 2 guiones cortos —

    Gracias por el tutorial

  15. He tratado de solucionar el “cuelgue” de kali al abrir iceweassel pero no he podido lograrlo ,tendran alguna solucion efectiva o deberia removerlo e instalar chrome?- gracias por la respuesta.

  16. he intentado mil veces instalar chrome en kali pero siempre me da un mensaje de erro que dice “error al procesar google-chrome-stable_current_i386.deb (–install):
    la arquitectura del paquete (i386) no corresponde con la del sistema (amd64)
    Se encontraron errores al procesar:” sabes como puedo solucionarlo???? de antemano muchas gracias.

DEJA UNA RESPUESTA

Por favor, introduzca su comentario!
Por favor, introduzca su nombre aquí