moodle-logoHoy toca hablar de un problema que puede surgir con una de las mejores aulas virtuales que existen, Moodle, seguramente ya la conozcas y la uses de vez en cuando, pues en esta ocasión vamos a resolver el problema “Command line scripts must define CLI_SCRIPT before requiring config.php” que aparece a la hora de acceder a Moodle para una configuración o instalación incorrecta.

Este error viene provocado concretamente por la variable:

$_SERVER[‘REMOTE_ADDR’]

cuando no esta correctamente definida, pero para solucionarlo de forma rápida vamos a indicaros a continuación el proceso a seguir:

Lo primero que debemos de hacer es abrir el archivo lib/setup.php de nuestra instalación de Moodle.

(Lo podemos abrir desde la terminal, ftp, o lo que más nos guste vamos)

Una vez dentro solo tenemos que comentar las siguientes lineas, de forma que estén desactivadas y no funcionen:

Podemos comentar estas lineas como muestro en el ejemplo anterior con # o si lo preferimos con // al principio de cada linea.

Y ya tenemos el error solucionado 😉

2
Deja una respuesta

avatar
2 Hilos de comentario
0 Respuestas de hilo
0 Seguidores
 
Comentario más reaccionado
El hilo de comentarios más caliente
1 Autores de comentarios
_rootBitacoras.com Autores de comentarios recientes
  Suscribirse  
Los más recientes Los más antiguos Más votados
Notificarme las
_root
Invitado
_root

if (!defined(‘CLI_SCRIPT’)) {
define(‘CLI_SCRIPT’, true);
}

trackback

Información Bitacoras.com

Valora en Bitacoras.com: Hoy toca hablar de un problema que puede surgir con una de las mejores aulas virtuales que existen, Moodle, seguramente ya la conozcas y la uses de vez en cuando, pues en esta ocasión vamos a resolver el problema “Command …