kernelAntes de ayer de madrugada se publico la versión final del kernel 3.15, la cual corresponde a su primera versión estable en dicha rama, siendo esta la 3.15, la cual explicaremos como instalar en su versión normal y la de baja latencia.

Información útil:

¿Qué es y para que se usa el Kernel de baja latencia? (lowlatency)

¿Como eliminar los Kernels antiguos?

Novedades:

En esta primera versión del kernel 3.15 podemos encontrar la presencia de novedades y mejoras en diversos aspectos como: el modo mixto de EFI, gracias al cual se podrá ejecutar Linux 64-bit en un sistema con UEFI 32-bit; mejoras en los tiempos de suspensión y reanimación y, como siempre, muchas novedades en lo que respecta a controladores gráficos y hardware en general.

Por ejemplo, Linux 3.15 incluye soporte inicial para GPUs Maxwell de Nvidia en los controladores libres Nouveau; en los Radeon, soporte para codificación de vídeo VCE 2.0 en tarjetas recientes. Como curiosidad, Linux 3.15 da soporte al DualShock 4 de PlayStation 4.

Para más información visita el anuncio oficial: Anuncio kernel 3.15

Esta instalación es valida para Ubuntu, Mint y Debian para sistemas de 32 Bits, serían a través de una terminal con las siguientes ordenes, primero descargamos los paquetes:

Versión normal (32bits):

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-headers-3.15.0-031500_3.15.0-031500.201406131105_all.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-headers-3.15.0-031500-generic_3.15.0-031500.201406131105_i386.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-image-3.15.0-031500-generic_3.15.0-031500.201406131105_i386.deb

Versión de baja latencia para el kernel (lowlatency) (32bits):

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-headers-3.15.0-031500_3.15.0-031500.201406131105_all.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-headers-3.15.0-031500-lowlatency_3.15.0-031500.201406131105_i386.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-image-3.15.0-031500-lowlatency_3.15.0-031500.201406131105_i386.deb

Y finalmente, los instalamos con:

$ sudo dpkg -i linux-headers-3.15*.deb linux-image-3.15*.deb

Para su instalación en sistemas de 64 Bits, descargamos con:

Versión normal (64bits):

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-headers-3.15.0-031500_3.15.0-031500.201406131105_all.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-headers-3.15.0-031500-generic_3.15.0-031500.201406131105_amd64.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-image-3.15.0-031500-generic_3.15.0-031500.201406131105_amd64.deb

Versión de baja latencia para el kernel (lowlatency) (64bits):

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-headers-3.15.0-031500_3.15.0-031500.201406131105_all.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-headers-3.15.0-031500-lowlatency_3.15.0-031500.201406131105_amd64.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-image-3.15.0-031500-lowlatency_3.15.0-031500.201406131105_amd64.deb

E instalamos también con:

$ sudo dpkg -i linux-headers-3.15*.deb linux-image-3.15*.deb

Reiniciamos el sistema, y seccionamos la versión con la que queramos iniciar en el GRUB o BURG.

Fuente: Kernel – Ubuntu.

21 COMENTARIOS

  1. Buen día Noel, sigamos en limpio nuestro “hilo” por acá… digo, porque tantas respuestas anidadas en los comentarios se complica un poco 🙂

    Si es “envidia” mi video… puede venir por ahí el cuelgue de la versión 3.15 del Kernel. Ya que tras reiniciar, luego del post, se veían algunos pantallazos rayados, negros, multicolores.. la típica falla del driver de video en linux.

    Haré una imagen de disco antes de probar actualizar la ¿3°? colección de paquetes. Pregunto lo de 3°, porque vos decís quw volvieron a subir las partes del núcleo… están actualizados tus links wget?

    Pregunto, porque a la vuelta del finde lo intentaré. Ahora me estoy yendo a festejar el día del padre a mis pagos (portena.gob.ar); con mi Viejo y familia…

    Te mando un abrazo, muchas gracias por explayarte tanto!

    Saludos,

    Richy

    • Em. haber me refiero que tu versión de nvidia es vieja/antigua y rechaza esta nueva versión del kernel, tienes que instalarte la versión más moderna de nvidia para actualizar el kernel.
      Pd. también puedes probar a instalar el kernel y luego instalar nvidia.

  2. $ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/linux-headers-3.15.0-031500_3.15.0-031500.201406081435_all.deb
    –2014-06-12 11:48:10–
    Resolviendo kernel.ubuntu.com (kernel.ubuntu.com)… 91.189.94.216
    Conectando con kernel.ubuntu.com (kernel.ubuntu.com)[91.189.94.216]:80… conectado.

    Petición HTTP enviada, esperando respuesta… 404 Not Found
    2014-06-12 11:48:11 ERROR 404: Not Found.

    Hola Noel… favor de revisar… muchas gracias!

    • Ya esta corregido, y te comento lo que observe aunque no se el motivo por el cual paso: el kernel 3.15 precompilado de ubuntu fue cambiado/actualizado/o lo que fuera (no tengo ni idea), lo que se es que este kernel salio el día 8,de madrugada, yo hice el articulo el día 9 de noche y ayer 11 a las 17:01h los cambiaron por otras compilaciones del mismo kernel, según las fechas que acabo de ver.

      Con lo que todos los pasos del tutorial darían error ya que borraron los otros y pusieron estos, no vi noticias sobre el porque, pero ya esta solucionado y funciona correctamente, gracias por avisar, un saludo.

      • gracias a Vos por tu pronta respuesta!

        Ahora mismo lo actualizaré… no alcancé a instalar aquella versión que dices que salió errónea, menos mal..

        Cuando vi el error en tu Web, busqué bajar yo mismo los .deb actualizados… pero no lo encontré, ni siquiera en kernel.ubuntu.com

        Que tengas un gran día, muchas gracias por tus aportes

        • Si hubieras intentado actualizar con el anterior te daría error en todos, así que no te preocupes y si te fijas el código del anterior acababa en “031500.201406081435_all.deb” y el de ahora en “031500.201406111300_all.deb” es otra diferencia aparte de la hora que demuestra que algo cambio.
          Si quieres ver los paquetes mira la fuente del articulo, la cito para que veáis de donde saco los repositorios.

          • Hola Noel, aquí vuelvo…
            Menos mal que se trataba de un equipo nuevo, sin archivos importantes, pues, luego de descargar los tres paquetes para mi Linux Mint Qiana 17 x86_64 MATE y ejecutar la instalación (compilación) del nuevo Kernel, el equipo no arrancó nunca más:

            La instalación se llevó a cabo sin errores, ni alertas… sin embargo, cuando reinicié, ya no tenía GRUB, ni video, ni inicio, ni nada. 🙁

            Tuve que reinstalar, ya que no encontré forma de llegar a alguna pantalla “potable”, como la de recuperación, modo de errores, etc….

            La verdad, no sé por qué pasó. Estoy siempre bien atento a la hora de actualizar un Kernel, no le habrás “errado” vos con algún paquete…?

            Alguien que me confirme que lo probó en Linux Mint 17 x86_64 y le anduvo…. y volveré a intentarlo,

            Muchas gracias, Saludos!

            • Buenas richy, acabo de comprobar todos los enlaces y están perfectos, incluso intente comparar con otras webs pero las únicas que encontré con un tuto similar están con los enlaces viejos con lo que no funcionan.
              Y una cosa ¿instalaste este precompilado o lo compilaste tu solo en el ordenador?
              Lo que me cuentas es extraño, no lo voy a negar, por que aun que este kernel te falle (que no debería) te tendrían que salir los otros en más opciones del grub e iniciar con el que te de la gana, pero al parecer ni eso.
              Un consejo que te doy, cuando te quedes sin grub utiliza este programa desde un live boot repair, te arreglara el grub y listo.
              Yo en mi Ubuntu sin fallos, esta noche vaya una iso de linux mint y lo hago por medio de una maquina virtual a ver si me pasa o no.
              Pero eso, debería de irte igual que todos los anteriores que publique.

              • Exacto Noel, jamás me quedo con un solo Kernel…
                Siempre trato de usar el último, y me guardo los dos anteriores en el GRUB, como para poder zafar si algo falla…

                He actualizado infinidad de Kernels siguiendo tus instrucciones, siempre con los mismos pasos:

                Bajo los 3 archivos con el wget que indicas tu… instalo con el dpkg que también nos proporcionas… reinicio la PC, y lo selecciono en el GRUB. Más sencillo, imposible!!!

                A qué te refieres con…
                “¿instalaste este precompilado o lo compilaste tu solo en el ordenador?”

                Lo instalé como te acabo de contar…

                Anda, si puedes hacerme el grandísimo favor de probar en una máquina virtual con Mint… just do it y luego me comentas, mis más infinitas gracias!!

                Richy

                • PD: Imposible lo del BootRepair… ya que luego de instalar el Kernel y reiniciar… nunca más llegué a abrir el Sistema Operativo.

                  • Estoy bajando la iso estándar de linux mont 17 con cinamon, en 1h aprox experimento y te comento, y lo otro nada, si sigues mis tutos ya me respondiste a la pregunta, es que otros prefieren compilarlo ellos mismos, y yo utilizo paquetes ya compilados con lo que ahorro 30min por lo menos a costa de muy poco en mi opinión.
                    Por el momento no actualices y usa lo tuyo normal y eso,que no quiero que te de otro fallo a saber porque, en una hora y poco ya te digo por aquí lo que averiguo.

                    • Por los foros de linux mint encontre este caso, al parecer el cosa de nvidia, que seguramente tengas instalada en tu ordenador ¿cierto?, por lo que leí basta con actualizar a su ultima versión y listo. Lee el post por si ves alguna cosa más que te ayude, pero creo que esa es la clave.

                      En mi instalación de mint pues el resultado fue: instalación sin fallos del kernel y mint me funciona sin fallos, cabe destacar que lo hice todo en mint cinamon sin instalar nada, con lo que reafirmo la conclusión de arriba, nvidia choca.

                      Pd. No se que pasa pero es la 2º vez que cambian los paquetes precompilados, ahora mismo si entras veran un nombre nuevo de archivo y la fecha de la subida de estos paquetes nuevos “13-Jun-2014 15:06”, no me quiero arriesgar a lanzar conclusiones porque no tengo ni idea, pero la respuesta creo que esta en unos archivos de construcción de logs (ni idea) que hay ahora en el directorio. De todas formas no creo que sea algo para preocupar si a los que ya actualizaron antes, ya que si fuera así veríamos algún comunicado por la red.

                  • ahh, y se me acaba de venir, si lo boteas desde un live, te funciona “sudo apt-get remove linux-headers-3.15* linux-image-3.15*”, esto desinstalaría el kernel 3.15 que al parecer te bloquea el ordenador.

                    • Hola Noel, vuelvo al ruedo… perdón por “el bache” que dejé por acá, sucede que me ganó el trabajo…

                      No hay caso, no hay forma de instalar cualquier Kernel de la versión 3.15 en adelante en mi Notebook… 🙁

                      Estuve leyendo, investigando y probando mucho y, encontré que el amigo Torvalds, a partir de la versión 3.15 de su Kernel, quitó en el mismo el soporte para algunas placas de video algo antiguas…

                      Creo que este tema da para hacer un post, decide tu Administrador…

                      Te comento mi caso:
                      Probamos de todas formas contigo instalar el Kernel 3.15 en mi Notebook. El problema era (es) que tras reiniciar, da una pantalla negra que ni siquiera muestra el GRUB. Aquí podría contar en el post, como lo solucioné, que no fue iniciando con un live CD como vos me sugeriste, ya que encontré otra forma más rápida que milagrosamente funcionó.

                      OK luego vi que salió la versión 3.15.1 del Kernel…
                      También la probé y exactamente con los mismos resultados.

                      Definitivamente, el driver ‘noveau’ que incluyen las versiones del Kernel, desde la 3.15… no funciona con mi placa.

                      Se te ocurre algo?
                      Actualmente estoy usando el Kernel 3.14.0 que ya había usado antes y funcionaba OK, y lo sigue haciendo… además corrige un problema con la administración de energía del equipo, que era muy molesto.

                      Pues bien, repito, se te ocurre algo que pueda intentar para estar a la última en mi Notebook, y no tener que descartar esta distro, que es la que mejores resultados me ha dado…?

                      Aquí tienes mis modelos (Notebook y placa de video) =>
                      vaio@vaio-VGN-CR440F ~ $ lspci | grep -i vga
                      00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

                      Muchśimas gracias por seguir ahí,

                      Richy

                    • Creo que ese no es tu caso, acabo de buscar información con tu modelo y me encontré con esto bugs-launchpad, con lo que me temo que es un bug, para mañana haré un tutorial para instalar la actualización del kernel 3.15 al 3.15.1 haber si con eso se soluciona el problema.

                    • Si, es lo mismo que yo publicare en 6h jje, me da que el lo hace igual que yo, con la diferencia del idioma.
                      Me da que tendrás que esperar al 3.15.2 al menos para ver si solucionan tu error, o sino ya sabes nvidia en tu versión actual fuera.

                    • Perdón Noel, pero no sé anidar más respuestas… ergo, te respondo por el general 🙂

                      Grandioso el dato que me aportaste con lo del Launchpad, si te fijas…verás que yo dejé ahí mi granito de arena.

                      Estaremos atentos, a ver si en la release 15.2 del Kernel, solucionan el problema.

                      Dices 6hr… dónde estás? Qué diferencia horaria tienes con Argentina? Perdón, pero no encontré about, ni quién soy, ni sobre mi, en tu blog,

                      Buenas noches, nos estamos escribiendo!

                      Richy

  3. mi único inconveniente es que nunca publican el modo de hacerlo desde otro distro que no se ubuntu por ejemplo centos o fedora

    • Me informare sobre ello, pero no prometo nada, ya que no se ni si fedora tiene un repositorio de kernels compilados como ubuntu y también de como es el paso a seguir.
      Si me puedes echar una mano seria genial.

  4. Información Bitacoras.com

    Valora en Bitacoras.com: Antes de ayer de madrugada se publico la versión final del kernel 3.15, la cual corresponde a su primera versión estable en dicha rama, siendo esta la 3.15, la cual explicaremos como instalar en su versión normal y la de b…

DEJA UNA RESPUESTA

Por favor, introduzca su comentario!
Por favor, introduzca su nombre aquí