kernel Ayer mismo se publicaba la versión definitiva y oficial del kernel 4.4, la versión más moderna a día de hoy del Kernel Linux, el cual explicaremos como instalar en su versión normal y la de baja latencia.

Información útil:

¿Qué es y para que se usa el Kernel de baja latencia? (lowlatency)

¿Como eliminar los Kernels antiguos en Debian, Ubuntu y derivados?

¿Como eliminar los Kernels antiguos en Fedora y derivados?

Novedades:

En esta nueva versión de kernel podemos destacar una la adicción del soporte 3D en la GPU Virtual Driver y que este kernel es LTS (Con soporte de largo tiempo), entre otros cambios tenemos la actualización de numerosos controladores y softwares incorporados al código.

Para más información visita el anuncio oficial: Anuncio kernel 4.4

Esta instalación es valida para Ubuntu, Mint y Debian para sistemas de 32 Bits, serían a través de una terminal con las siguientes ordenes, primero descargamos los paquetes:

Versión normal (32bits):

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400_4.4.0-040400.201601101930_all.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400-generic_4.4.0-040400.201601101930_i386.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-image-4.4.0-040400-generic_4.4.0-040400.201601101930_i386.deb

Versión de baja latencia para el kernel (lowlatency) (32bits):

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400_4.4.0-040400.201601101930_all.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400-lowlatency_4.4.0-040400.201601101930_i386.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-image-4.4.0-040400-lowlatency_4.4.0-040400.201601101930_i386.deb

Y finalmente, los instalamos con:

$ sudo dpkg -i linux-headers-4.4*.deb linux-image-4.4*.deb

Para su instalación en sistemas de 64 Bits, descargamos con:

Versión normal (64bits):

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400_4.4.0-040400.201601101930_all.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400-generic_4.4.0-040400.201601101930_amd64.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-image-4.4.0-040400-generic_4.4.0-040400.201601101930_amd64.deb

Versión de baja latencia para el kernel (lowlatency) (64bits):

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400_4.4.0-040400.201601101930_all.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-headers-4.4.0-040400-lowlatency_4.4.0-040400.201601101930_amd64.deb

$ wget -c kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/linux-image-4.4.0-040400-lowlatency_4.4.0-040400.201601101930_amd64.deb

E instalamos también con:

$ sudo dpkg -i linux-headers-4.4*.deb linux-image-4.4*.deb

Reiniciamos el sistema, y seccionamos la versión con la que queramos iniciar en el GRUB o BURG.

Fuente: Kernel – Ubuntu.

7
Deja una respuesta

avatar
3 Hilos de comentario
4 Respuestas de hilo
0 Seguidores
 
Comentario más reaccionado
El hilo de comentarios más caliente
3 Autores de comentarios
SargentoJonNoelducados Autores de comentarios recientes
  Suscribirse  
Los más recientes Los más antiguos Más votados
Notificarme las
Sargento
Invitado
Sargento

😀

Jon
Invitado
Jon

Aupi, estoy teniendo problemas para instalar el kernel, os pego lo que me sale en consola:

(Leyendo la base de datos … 269893 ficheros o directorios instalados actualmente.)
Preparing to unpack linux-headers-4.4.0-040400_4.4.0-040400.201601101930_all.deb …
Unpacking linux-headers-4.4.0-040400 (4.4.0-040400.201601101930) over (4.4.0-040400.201601101930) …
Preparing to unpack linux-headers-4.4.0-040400-generic_4.4.0-040400.201601101930_amd64.deb …
Unpacking linux-headers-4.4.0-040400-generic (4.4.0-040400.201601101930) over (4.4.0-040400.201601101930) …
Preparing to unpack linux-image-4.4.0-040400-generic_4.4.0-040400.201601101930_amd64.deb …
Done.
Unpacking linux-image-4.4.0-040400-generic (4.4.0-040400.201601101930) over (4.4.0-040400.201601101930) …
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-040400-generic /boot/vmlinuz-4.4.0-040400-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-040400-generic /boot/vmlinuz-4.4.0-040400-generic
Configurando linux-headers-4.4.0-040400 (4.4.0-040400.201601101930) …
Configurando linux-headers-4.4.0-040400-generic (4.4.0-040400.201601101930) …
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.4.0-040400-generic /boot/vmlinuz-4.4.0-040400-generic
Error! Bad return status for module build on kernel: 4.4.0-040400-generic (x86_64)
Consult /var/lib/dkms/vboxhost/4.3.28/build/make.log for more information.
Error! Bad return status for module build on kernel: 4.4.0-040400-generic (x86_64)
Consult /var/lib/dkms/virtualbox-guest/4.3.18/build/make.log for more information.
Error! Bad return status for module build on kernel: 4.4.0-040400-generic (x86_64)
Consult /var/lib/dkms/fglrx-core/15.200/build/make.log for more information.
Configurando linux-image-4.4.0-040400-generic (4.4.0-040400.201601101930) …
Running depmod.
update-initramfs: deferring update (hook will be called later)
Not updating initrd symbolic links since we are being updated/reinstalled
(4.4.0-040400.201601101930 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(4.4.0-040400.201601101930 was configured last, according to dpkg)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-040400-generic /boot/vmlinuz-4.4.0-040400-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-040400-generic /boot/vmlinuz-4.4.0-040400-generic
Error! Bad return status for module build on kernel: 4.4.0-040400-generic (x86_64)
Consult /var/lib/dkms/virtualbox-guest/4.3.18/build/make.log for more information.
Error! Bad return status for module build on kernel: 4.4.0-040400-generic (x86_64)
Consult /var/lib/dkms/fglrx-core/15.200/build/make.log for more information.
Error! Bad return status for module build on kernel: 4.4.0-040400-generic (x86_64)
Consult /var/lib/dkms/vboxhost/4.3.28/build/make.log for more information.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-040400-generic /boot/vmlinuz-4.4.0-040400-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-040400-generic
Warning: No support for locale: es_ES.utf8
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.4.0-040400-generic /boot/vmlinuz-4.4.0-040400-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.4.0-040400-generic /boot/vmlinuz-4.4.0-040400-generic
Generando archivo de configuración grub…
Aviso: Ya no se permite establecer GRUB_TIMEOUT a un valor distinto de cero cuando GRUB_HIDDEN_TIMEOUT está activado.
Found linux image: /boot/vmlinuz-4.4.0-040400-generic
Found initrd image: /boot/initrd.img-4.4.0-040400-generic
Found linux image: /boot/vmlinuz-4.2.0-040200-generic
Found initrd image: /boot/initrd.img-4.2.0-040200-generic
Found linux image: /boot/vmlinuz-3.13.0-37-generic
Found initrd image: /boot/initrd.img-3.13.0-37-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
No volume groups found
hecho

Alguien sabe que puede pasar?

Un saludo

ducados
Invitado
ducados

hola

Acabo de reinstalar ubuntu 14.04 he instalado este kernel 4.4 sin problemas y quería instalar el driver de nvidia 352.63 de su pagina oficial

he salido del entorno grafico y desde la tt1 me he logeado y reiniciado luego he vuelto a la tt1 y sudo sh NVIDIA.run

no me ha dejado instalar el driver el resultado es: enable to build the nvidia

tienes alguna solución?

gracias y saludos